Book Errata & Updates

List of Updates and Bug Fixes for “Basic Security Testing with Kali Linux, 3rd Edition”:


Webdelivery PowerShell Reverse_tcp Shell not Working


There is currently a Metasploit WebScript PowerShell issue in 2018.3 that prevents the reverse_tcp shell from being created.

Recommended Fix – Download and use Kali Linux 2018.2 for the book.

The Image for 2018.2 can be found at https://cdimage.kali.org/kali-images/kali-2018.2/. Note: If you update 2018.2, it will pull down the current version that has the bug.

The effected Metasploit versions seem to be Framework v4.17.5-dev through Framework v4.17.9-dev. Earlier versions work fine. Both Kali Linux and Metasploit have been notified of the issue.

https://github.com/rapid7/metasploit-framework/issues/10502

Advertisements